Menu Home

MEMBATASI BANDWITH MIKROTIK DENGAN SIMPLE QUEUE

Membatasi Bandwith Mikrotik Dengan Simple Queue – Artikel kali ini akan membahas tentang cara membatasi bandwith mikrotik dengan simple queue setelah artikel sebelumnya membahas tentang setting hotspot di mikrotik. Pada artikel sebelum memang sudah dijelaskan bagaimana cara membatasi bandwith tiap user. Kali ini saya akan memberikan opsi lain dalam menyetting hotspot di mikorting. Kita ambil sebuah kasus :

Sebuah ISP mempunyai bandwith 2 Mb dan terdiri dari 10 user, setiap user diberi kecepatan 256kb. Jika menggunakan metode pembagian bandwith seperti pada artikel setting hotspot di mikrotik memang setiap user bisa mendapatkan 256kb akan tetapi bagaimana jika hanya ada 1 user saja yang online, apakah akan tetap mendapatkan 256k atau bisa full mendapatkan bandwith 2Mb ? Jawabannya adalah iya hanya 256kb. Oleh karena itu untuk memaksimalkan bandwith sehingga tidak ada bandwith “nganggur” ketika user kosong bisa digunakan dengan menggunakan simple queue.

Kita akan membuat sebuah sistem yang memungkinkan 1 user bisa menggunakan seluruh bandwith 2 Mb jika kondisi hanya ada 1 user saja yang online. Apabila kondisi penuh setiap user minimal akan mendapatkan jatah 256kb. Bagaimana caranya? Kita ikuti alur berikut ini :

1.  Pertama setting hotspot terlebih dahulu. Tutorial bisa dilihat di SETTING HOTSPOT DI MIKROTIK (cukup sampai no.16 saja)

2.  Kedua kita membuat usernya, ketikkan perintah berikut

User 1

/ip hotspot user add server=all name=user_1 password=1234 address=11.11.11.1 profile=default

User 2

/ip hotspot user add server=all name=user_1 password=1234 address=11.11.11.1 profile=default

*catatan = profile selalu pilih default sehingga nantinya bandwith bisa kita atur di simple queue

3.  Ketiga kita akan membuat mangle nya. Buka New terminal lalu ketikkan :

Manggle ICMP Ping

/ip firewall mangle add chain=prerouting protocol=icmp action=mark-connection new-connection-mark=PingStabil passthrough=yes comment=ICMP_Ping
/ip firewall mangle add chain=prerouting protocol=icmp action=mark-packet new-packet-mark=PingPaket passthrough=no

Manggle Browsing

/ip firewall mangle add chain=prerouting protocol=tcp dst-port=80 action=mark-connection new-connection-mark=BrowsingCon passthrough=yes comment=BROWSING
 /ip firewall mangle add chain=prerouting connection-mark=BrowsingCon action=mark-packet new-packet-mark=BrowsingPaket passthrough=no

*catatan : pastikan ICMP ping berada di atas Browsing agar prioritas akan diberikan ke ICMP Ping

4.   Membuat queue. Buka New terminal lalu ketikkan :

Parent Browsing

/queue simple add name=Browsing interface=all parent=none priority=8 queue=default/default max-limit=2M/2M total-queue=default disabled=no packet-marks=BrowsingPaket

Turunan Browsing

/queue simple add name=user_1 target-addresses=11.11.11.1 interface=all parent=Browsing priority=8 queue=default/default limit-at=0/256k max-limit=2M/2M total-queue=default disabled=no
 /queue simple add name=user_2 target-addresses=11.11.11.12 interface=all parent=Browsing priority=8 queue=default/default limit-at=0/256k max-limit=2M/2M total-queue=default disabled=no

Saya ambil contoh 2 user, jika anda 10 user tinggal menambahkan saja.

ICMP Ping

/queue simple add name="ICMP_Ping" interface=all parent=none priority=2 queue=default/default max-limit=0/0 total-queue=default disabled=no packet-marks=PingPaket

Penjelasan fungsi di simple queue :

Name : nama identitas misalkan user_1 atau mungkin PC 1, dsb sesuai keinginan anda

Target address : alamat ip yang akan digunakan, dalam kasus ini alamat ip ini harus disusaikan dengan ip di user (lihat no.2)

Priority : Bandwith yang diprioritaskan terlebih dahulu. Priorty 1 berarti mendaptkan prioritas pertama sedangkan priority 8 berarti mendapatkan prioritas terakhir (priority ada 1 – 8)

Limit at : bandwidth yang akan didapatkan saat jaringan paling sibuk (Committed Information Rate)

Max limit : kecepatan maksimum yang mungkin didapatkan saat jaringan tidak sibuk (Maximum Information Rate)

Contoh kasus limit at dan max limit. Seperti kasus di awal kita analogikan seuah ISP mempunyai bandwith 2 MB dan terdiri dari 10 user. Satu ketika trafic full, semua user sedang online maka setiap user minimal akan mendapatkan jatah bandwith 256k (limit at). Sebaliknya jika pada suatu ketika hanya ada 1 orang saja yang online, maka user diizinkan melewati limit at dan bisa menggunakan maksimal bandwith yaitu sebesar 2 M (max limit).

*catatan : perlu perhitungan matang ketika setting limit at. Jika kita hanya mempunyai bandwith kecil misalnya 512k dan mempunya 10 user tentunya kita tidak mungkin mengisi 256k karena akan berdampak pada kecepatan user.

Categories: Hotspot Mikrotik

Tagged as:

alur data

1 reply

Leave a Reply

Your email address will not be published. Required fields are marked *